Grasshopper -- Toll Free ordering issues
Incident Report for Grasshopper
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted about 2 months ago. Jun 27, 2019 - 22:46 UTC
Identified
We are aware that some Grasshopper customers may be experiencing issues with ordering Toll Free numbers.

Our engineers have identified the source of the problem, and are working to resolve the issue and will provide another update shortly.
Posted about 2 months ago. Jun 27, 2019 - 17:14 UTC
This incident affected: Grasshopper.